package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{2,}\d+(*SKIP)(*FAIL)|[A-Z](\d+)`)
var str = `A12B8Y9CC10
V5C8I17
KK18II9
I8VV22ZZ4S9U2
A18Z12I`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}