import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{2,}\\d+(*SKIP)(*FAIL)|[A-Z](\\d+)";
final String string = "A12B8Y9CC10\n"
+ "V5C8I17\n"
+ "KK18II9\n"
+ "I8VV22ZZ4S9U2\n"
+ "A18Z12I";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}