using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ \-a-zA-Z.]+\s+(\d+(\s?\w$)?)";
string input = @"Lilienstr. 12a
Hagentorwall 3
Seilerstr. 14 (Eingang Birkenstr.)
Guentherstr. 43 B
Eberhard-Leibnitz Str. 1 WH 5B 241
1019-1781 Borderlinx C/O SEKO Logistics
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}