re = /^[ \-a-zA-Z.]+\s+(\d+(\s?\w$)?)/m
str = 'Lilienstr. 12a
Hagentorwall 3
Seilerstr. 14 (Eingang Birkenstr.)
Guentherstr. 43 B
Eberhard-Leibnitz Str. 1 WH 5B 241
1019-1781 Borderlinx C/O SEKO Logistics
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end