// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[ \-a-zA-Z.]+\s+(\d+(\s?\w$)?)").unwrap();
let string = "Lilienstr. 12a
Hagentorwall 3
Seilerstr. 14 (Eingang Birkenstr.)
Guentherstr. 43 B
Eberhard-Leibnitz Str. 1 WH 5B 241
1019-1781 Borderlinx C/O SEKO Logistics
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}