package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[ \-a-zA-Z.]+\s+(\d+(\s?\w$)?)`)
var str = `Lilienstr. 12a
Hagentorwall 3
Seilerstr. 14 (Eingang Birkenstr.)
Guentherstr. 43 B
Eberhard-Leibnitz Str. 1 WH 5B 241
1019-1781 Borderlinx C/O SEKO Logistics
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}