using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(?<!\S)opt3(?!\S))filename\.txt";
string input = @"filename.txt opt1 opt2 opt4 testopt3test
filename.txt opt1 opt2 opt4 $opt3#
filename.txt opt1 opt2 opt4 opt3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}