const regex = new RegExp('^(?!.*(?<!\\S)opt3(?!\\S))filename\\.txt', 'gm')
const str = `filename.txt opt1 opt2 opt4 testopt3test
filename.txt opt1 opt2 opt4 \$opt3#
filename.txt opt1 opt2 opt4 opt3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}