re = /^(?!.*(?<!\S)opt3(?!\S))filename\.txt/m
str = 'filename.txt opt1 opt2 opt4 testopt3test
filename.txt opt1 opt2 opt4 $opt3#
filename.txt opt1 opt2 opt4 opt3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end