import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?<!\\S)opt3(?!\\S))filename\\.txt";
final String string = "filename.txt opt1 opt2 opt4 testopt3test\n"
+ "filename.txt opt1 opt2 opt4 $opt3#\n"
+ "filename.txt opt1 opt2 opt4 opt3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}