#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi).*(hello.+you).*"
Local $sString = "aaaHello will get match with the last you, you see?" & @CRLF & _
"Also this hello won't get selected, but the last one will, hello you!" & @CRLF & _
"Here this hello you combo won't get selected, but the last will, hello, you see?" & @CRLF & _
"Btw, you might wondering why do you see blue on everything, welp, that's all I can do, if theres no he-llo you combination it won't match, otherwise it matches everything as group 0, and the word you need as group 1. (so yea just take data group 1 and it's gud)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")