use strict;
my $str = 'aaaHello will get match with the last you, you see?
Also this hello won\'t get selected, but the last one will, hello you!
Here this hello you combo won\'t get selected, but the last will, hello, you see?
Btw, you might wondering why do you see blue on everything, welp, that\'s all I can do, if theres no he-llo you combination it won\'t match, otherwise it matches everything as group 0, and the word you need as group 1. (so yea just take data group 1 and it\'s gud)';
my $regex = qr/.*(hello.+you).*/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}