import Foundation
let pattern = #".*(hello.+you).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
aaaHello will get match with the last you, you see?
Also this hello won't get selected, but the last one will, hello you!
Here this hello you combo won't get selected, but the last will, hello, you see?
Btw, you might wondering why do you see blue on everything, welp, that's all I can do, if theres no he-llo you combination it won't match, otherwise it matches everything as group 0, and the word you need as group 1. (so yea just take data group 1 and it's gud)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)