$re = '/.*(hello.+you).*/mi';
$str = 'aaaHello will get match with the last you, you see?
Also this hello won\'t get selected, but the last one will, hello you!
Here this hello you combo won\'t get selected, but the last will, hello, you see?
Btw, you might wondering why do you see blue on everything, welp, that\'s all I can do, if theres no he-llo you combination it won\'t match, otherwise it matches everything as group 0, and the word you need as group 1. (so yea just take data group 1 and it\'s gud)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);