package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9](?:[a-zA-Z0-9 _-]*[a-zA-Z0-9])?\.[a-zA-Z0-9_-]+$`)
var str = `## BELOW SHOULD MATCH
web.config
httpd.conf
test.txt
1.1
my long file name.txt
## BELOW SHOULD NOT MATCH
æøå.txt
hosts
.gitignore
.htaccess
test.t xt
web.config.txt
httpd.conf
\httpd.conf
/httpd.conf
test.zip.txt
sdasdf.doc
sdas_-df.doc
sdas/df.doc
sd\asdf.doc
hai cats or dogs
.txt
awdsf.txt.txt.doc.docx
1.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}