import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9](?:[a-zA-Z0-9 _-]*[a-zA-Z0-9])?\\.[a-zA-Z0-9_-]+$";
final String string = "## BELOW SHOULD MATCH\n"
+ "web.config\n"
+ "httpd.conf\n"
+ "test.txt\n"
+ "1.1\n"
+ "my long file name.txt\n\n"
+ "## BELOW SHOULD NOT MATCH\n"
+ "æøå.txt\n"
+ "hosts\n"
+ ".gitignore\n"
+ ".htaccess\n"
+ "test.t xt\n"
+ "web.config.txt\n"
+ "httpd.conf\n"
+ "\\httpd.conf\n"
+ "/httpd.conf\n"
+ "test.zip.txt\n"
+ "sdasdf.doc\n"
+ "sdas_-df.doc\n"
+ "sdas/df.doc\n"
+ "sd\\asdf.doc\n"
+ "hai cats or dogs\n"
+ ".txt\n"
+ "awdsf.txt.txt.doc.docx\n"
+ "1.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}