# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z0-9](?:[a-zA-Z0-9 _-]*[a-zA-Z0-9])?\.[a-zA-Z0-9_-]+$"
test_str = ("## BELOW SHOULD MATCH\n"
"web.config\n"
"httpd.conf\n"
"test.txt\n"
"1.1\n"
"my long file name.txt\n\n"
"## BELOW SHOULD NOT MATCH\n"
"æøå.txt\n"
"hosts\n"
".gitignore\n"
".htaccess\n"
"test.t xt\n"
"web.config.txt\n"
"httpd.conf\n"
"\\httpd.conf\n"
"/httpd.conf\n"
"test.zip.txt\n"
"sdasdf.doc\n"
"sdas_-df.doc\n"
"sdas/df.doc\n"
"sd\\asdf.doc\n"
"hai cats or dogs\n"
".txt\n"
"awdsf.txt.txt.doc.docx\n"
"1.1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.