using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<div id=\""content\""[.\s\S]*?(?=\<div id=\""footer\"")";
string substitution = @"";
string input = @"hello this is some text I don't want
asdf
asdfasd
ff
<div id=""content"" class=""other"">
i have this other stuff
<div>More stuff</div>
<div id=""footer"">
hello^[^_]*_
asd;flkjasd
f;kas
dfas
df
asdf a2 5<div id=""footer""><div id=""content></div>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}