use strict;
my $str = 'hello this is some text I don\'t want
asdf
asdfasd
ff
<div id="content" class="other">
i have this other stuff
<div>More stuff</div>
<div id="footer">
hello^[^_]*_
asd;flkjasd
f;kas
dfas
df
asdf a2 5<div id="footer"><div id="content></div>';
my $regex = qr/\<div id=\"content\"[.\s\S]*?(?=\<div id=\"footer\")/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";