# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\<div id=\"content\"[.\s\S]*?(?=\<div id=\"footer\")"
test_str = ("hello this is some text I don't want\n"
"asdf\n"
"asdfasd\n"
"ff\n"
"<div id=\"content\" class=\"other\">\n"
"i have this other stuff \n"
"<div>More stuff</div>\n"
"<div id=\"footer\"> \n"
"hello^[^_]*_\n"
"asd;flkjasd\n"
"f;kas\n"
"dfas\n"
"df\n"
"asdf a2 5<div id=\"footer\"><div id=\"content></div>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.