import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<div id=\\\"content\\\"[.\\s\\S]*?(?=\\<div id=\\\"footer\\\")";
final String string = "hello this is some text I don't want\n"
+ "asdf\n"
+ "asdfasd\n"
+ "ff\n"
+ "<div id=\"content\" class=\"other\">\n"
+ "i have this other stuff \n"
+ "<div>More stuff</div>\n"
+ "<div id=\"footer\"> \n"
+ "hello^[^_]*_\n"
+ "asd;flkjasd\n"
+ "f;kas\n"
+ "dfas\n"
+ "df\n"
+ "asdf a2 5<div id=\"footer\"><div id=\"content></div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}