import Foundation
let pattern = #"\<div id=\"content\"[.\s\S]*?(?=\<div id=\"footer\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hello this is some text I don't want
asdf
asdfasd
ff
<div id="content" class="other">
i have this other stuff
<div>More stuff</div>
<div id="footer">
hello^[^_]*_
asd;flkjasd
f;kas
dfas
df
asdf a2 5<div id="footer"><div id="content></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)