import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/[a-zA-Z0-9]{1,8}(([0-9][A-Za-z])|([a-z][\\dA-Z])|([A-Z][\\da-z])|([a-z]\\d[\\da-z]))[a-zA-Z0-9]{0,8}\\/[a-zA-Z0-9]{1,8}(([0-9][A-Za-z])|([a-z][\\dA-Z])|([A-Z][\\da-z])|([a-z]\\d[\\da-z]))[a-zA-Z0-9]{0,8}$";
final String string = "/PlL4mU/wdWnZiJZFEd\n"
+ "/Fs8Py/mKKsO\n"
+ "/JTi/MYWvduH2rC\n"
+ "/9Cm9EW/zNVBRnMD\n"
+ "/DekOPg/EgrEd7yT\n"
+ "/Fs8Py/gbbd4\n"
+ "/PlL4mU/ihwYceHQVuBP\n"
+ "/s0A/z3ZNW4XF20JN\n"
+ "/TLGhNd/AnD9Nq\n"
+ "/PpUYX/v4DaFW62S\n"
+ "/9a67pes/7N1eT4mS16\n"
+ "/9GQ5A8/95Lo9O9fj\n"
+ "/miR/FeHxaOiM\n"
+ "/Fs8Py/gbbd4\n"
+ "/PlL4mU/ihwYceHQVuBP\n"
+ "/s0A/z3ZNW4XF20JN";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}