// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\/[a-zA-Z0-9]{1,8}(([0-9][A-Za-z])|([a-z][\dA-Z])|([A-Z][\da-z])|([a-z]\d[\da-z]))[a-zA-Z0-9]{0,8}\/[a-zA-Z0-9]{1,8}(([0-9][A-Za-z])|([a-z][\dA-Z])|([A-Z][\da-z])|([a-z]\d[\da-z]))[a-zA-Z0-9]{0,8}$").unwrap();
let string = "/PlL4mU/wdWnZiJZFEd
/Fs8Py/mKKsO
/JTi/MYWvduH2rC
/9Cm9EW/zNVBRnMD
/DekOPg/EgrEd7yT
/Fs8Py/gbbd4
/PlL4mU/ihwYceHQVuBP
/s0A/z3ZNW4XF20JN
/TLGhNd/AnD9Nq
/PpUYX/v4DaFW62S
/9a67pes/7N1eT4mS16
/9GQ5A8/95Lo9O9fj
/miR/FeHxaOiM
/Fs8Py/gbbd4
/PlL4mU/ihwYceHQVuBP
/s0A/z3ZNW4XF20JN";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}