const regex = /^\/[a-zA-Z0-9]{1,8}(([0-9][A-Za-z])|([a-z][\dA-Z])|([A-Z][\da-z])|([a-z]\d[\da-z]))[a-zA-Z0-9]{0,8}\/[a-zA-Z0-9]{1,8}(([0-9][A-Za-z])|([a-z][\dA-Z])|([A-Z][\da-z])|([a-z]\d[\da-z]))[a-zA-Z0-9]{0,8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\\/[a-zA-Z0-9]{1,8}(([0-9][A-Za-z])|([a-z][\\dA-Z])|([A-Z][\\da-z])|([a-z]\\d[\\da-z]))[a-zA-Z0-9]{0,8}\\\/[a-zA-Z0-9]{1,8}(([0-9][A-Za-z])|([a-z][\\dA-Z])|([A-Z][\\da-z])|([a-z]\\d[\\da-z]))[a-zA-Z0-9]{0,8}$', 'gm')
const str = `/PlL4mU/wdWnZiJZFEd
/Fs8Py/mKKsO
/JTi/MYWvduH2rC
/9Cm9EW/zNVBRnMD
/DekOPg/EgrEd7yT
/Fs8Py/gbbd4
/PlL4mU/ihwYceHQVuBP
/s0A/z3ZNW4XF20JN
/TLGhNd/AnD9Nq
/PpUYX/v4DaFW62S
/9a67pes/7N1eT4mS16
/9GQ5A8/95Lo9O9fj
/miR/FeHxaOiM
/Fs8Py/gbbd4
/PlL4mU/ihwYceHQVuBP
/s0A/z3ZNW4XF20JN`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}