#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([+][359]{3}([ |-])[2]\2[0-9]{3}\2[0-9]{4})\b"
Local $sString = "+359 2 222 2222" & @CRLF & _
"+359-2-222-2222" & @CRLF & _
"359-2-222-2222, +359/2/222/2222, +359-2 222 2222" & @CRLF & _
"+359 2-222-2222, +359-2-222-222, +359-2-222-22222" & @CRLF & _
"+359-2-222-2222"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")