import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([+][359]{3}([ |-])[2]\\2[0-9]{3}\\2[0-9]{4})\\b";
final String string = "+359 2 222 2222\n"
+ "+359-2-222-2222\n"
+ "359-2-222-2222, +359/2/222/2222, +359-2 222 2222\n"
+ "+359 2-222-2222, +359-2-222-222, +359-2-222-22222\n"
+ "+359-2-222-2222";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}