$re = '/([+][359]{3}([ |-])[2]\2[0-9]{3}\2[0-9]{4})\b/m';
$str = '+359 2 222 2222
+359-2-222-2222
359-2-222-2222, +359/2/222/2222, +359-2 222 2222
+359 2-222-2222, +359-2-222-222, +359-2-222-22222
+359-2-222-2222';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);