using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+][359]{3}([ |-])[2]\2[0-9]{3}\2[0-9]{4})\b";
string input = @"+359 2 222 2222
+359-2-222-2222
359-2-222-2222, +359/2/222/2222, +359-2 222 2222
+359 2-222-2222, +359-2-222-222, +359-2-222-22222
+359-2-222-2222";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}