#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:export\s+|)(?<key>[[:alnum:]_]+)\s*=\s*((?<quote>["'])?(?<val>.*?)\k<quote>?|)$"
Local $sString = "DOT_ENV=dotenv" & @CRLF & _
"#DOTENV=dotenv" & @CRLF & _
"DOT_ENV= asdf asf " & @CRLF & _
"DOTENV='dot env'" & @CRLF & _
"DOTENV="dot env"" & @CRLF & _
"DOT_ENV='dotenv'" & @CRLF & _
"DOT_ENV="DotEnv"" & @CRLF & _
"DOTENV="Dot\nEnv"" & @CRLF & _
"DOTENV="{"Dot":"Env"}"" & @CRLF & _
"export DOTENV="dotenv"" & @CRLF & _
"DOTENV ="dot env"" & @CRLF & _
"DOTENV= "dot env"" & @CRLF & _
"DOTENV = "dot env"" & @CRLF & _
"DOTENV=""" & @CRLF & _
"DOTENV="\""" & @CRLF & _
"DOTENV="DOTENV""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")