// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?:export\s+|)(?<key>[[:alnum:]_]+)\s*=\s*((?<quote>["'])?(?<val>.*?)\k<quote>?|)$"#).unwrap();
let string = "DOT_ENV=dotenv
#DOTENV=dotenv
DOT_ENV= asdf asf
DOTENV='dot env'
DOTENV=\"dot env\"
DOT_ENV='dotenv'
DOT_ENV=\"DotEnv\"
DOTENV=\"Dot\\nEnv\"
DOTENV=\"{\"Dot\":\"Env\"}\"
export DOTENV=\"dotenv\"
DOTENV =\"dot env\"
DOTENV= \"dot env\"
DOTENV = \"dot env\"
DOTENV=\"\"
DOTENV=\"\\\"\"
DOTENV=\"DOTENV\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}