$re = '/^(?:export\s+|)(?<key>[[:alnum:]_]+)\s*=\s*((?<quote>["\'])?(?<val>.*?)\k<quote>?|)$/m';
$str = 'DOT_ENV=dotenv
#DOTENV=dotenv
DOT_ENV= asdf asf
DOTENV=\'dot env\'
DOTENV="dot env"
DOT_ENV=\'dotenv\'
DOT_ENV="DotEnv"
DOTENV="Dot\\nEnv"
DOTENV="{"Dot":"Env"}"
export DOTENV="dotenv"
DOTENV ="dot env"
DOTENV= "dot env"
DOTENV = "dot env"
DOTENV=""
DOTENV="\\""
DOTENV="DOTENV"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);