const regex = /^(?:export\s+|)(?<key>[[:alnum:]_]+)\s*=\s*((?<quote>["'])?(?<val>.*?)\k<quote>?|)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:export\\s+|)(?<key>[[:alnum:]_]+)\\s*=\\s*((?<quote>["\'])?(?<val>.*?)\\k<quote>?|)$', 'mg')
const str = `DOT_ENV=dotenv
#DOTENV=dotenv
DOT_ENV= asdf asf
DOTENV='dot env'
DOTENV="dot env"
DOT_ENV='dotenv'
DOT_ENV="DotEnv"
DOTENV="Dot\\nEnv"
DOTENV="{"Dot":"Env"}"
export DOTENV="dotenv"
DOTENV ="dot env"
DOTENV= "dot env"
DOTENV = "dot env"
DOTENV=""
DOTENV="\\""
DOTENV="DOTENV"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}