#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)From\s*:\s*.*?([^"'<>\s]+@[^"<>\s]+\.[^"'<>\s]+)"
Local $sString = "From : dr-dscsda-ds-info@asdf.com" & @CRLF & _
"From:sadaedf@sdc.sdfds" & @CRLF & _
"From: sdcasdc <information@dsf.net> " & @CRLF & _
"From: "adads" <adsasd@adsc.cd>" & @CRLF & _
"From: <customercare@ddsaf.com>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")