package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)From\s*:\s*.*?([^"'<>\s]+@[^"<>\s]+\.[^"'<>\s]+)`)
var str = `From : dr-dscsda-ds-info@asdf.com
From:sadaedf@sdc.sdfds
From: sdcasdc <information@dsf.net>
From: "adads" <adsasd@adsc.cd>
From: <customercare@ddsaf.com>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}