using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"From\s*:\s*.*?([^""'<>\s]+@[^""<>\s]+\.[^""'<>\s]+)";
string input = @"From : dr-dscsda-ds-info@asdf.com
From:sadaedf@sdc.sdfds
From: sdcasdc <information@dsf.net>
From: ""adads"" <adsasd@adsc.cd>
From: <customercare@ddsaf.com>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}