$re = '/From\s*:\s*.*?([^"\'<>\s]+@[^"<>\s]+\.[^"\'<>\s]+)/i';
$str = 'From : dr-dscsda-ds-info@asdf.com
From:sadaedf@sdc.sdfds
From: sdcasdc <information@dsf.net>
From: "adads" <adsasd@adsc.cd>
From: <customercare@ddsaf.com>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);