// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)From\s*:\s*.*?([^"'<>\s]+@[^"<>\s]+\.[^"'<>\s]+)"#).unwrap();
let string = "From : dr-dscsda-ds-info@asdf.com
From:sadaedf@sdc.sdfds
From: sdcasdc <information@dsf.net>
From: \"adads\" <adsasd@adsc.cd>
From: <customercare@ddsaf.com>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}