import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^0-9]*[0-9])(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])[\\x21-\\x7e]{8,20}$";
final String string = "1abcderfggdgf\n"
+ "sdvhbsdifsdfsdf1\n"
+ "Ghhuidicbdbuhbdc\n"
+ "bhdbcdbebvuheY\n"
+ "uuvvvyuv1G\n"
+ "1Guhuuuyuyuby\n"
+ "Y%*&^$^%^(^(GVGVYUKVYTUHBKBUFygyygyg\n\n"
+ "ebfuiuberiueu23423HHII";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}