const regex = /^(?=[^0-9]*[0-9])(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])[\x21-\x7e]{8,20}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^0-9]*[0-9])(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])[\\x21-\\x7e]{8,20}$', '')
const str = `1abcderfggdgf
sdvhbsdifsdfsdf1
Ghhuidicbdbuhbdc
bhdbcdbebvuheY
uuvvvyuv1G
1Guhuuuyuyuby
Y%*&^\$^%^(^(GVGVYUKVYTUHBKBUFygyygyg
ebfuiuberiueu23423HHII`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}