$re = '/^(?=[^0-9]*[0-9])(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])[\x21-\x7e]{8,20}$/';
$str = '1abcderfggdgf
sdvhbsdifsdfsdf1
Ghhuidicbdbuhbdc
bhdbcdbebvuheY
uuvvvyuv1G
1Guhuuuyuyuby
Y%*&^$^%^(^(GVGVYUKVYTUHBKBUFygyygyg
ebfuiuberiueu23423HHII';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);