use strict;
my $str = '1abcderfggdgf
sdvhbsdifsdfsdf1
Ghhuidicbdbuhbdc
bhdbcdbebvuheY
uuvvvyuv1G
1Guhuuuyuyuby
Y%*&^$^%^(^(GVGVYUKVYTUHBKBUFygyygyg
ebfuiuberiueu23423HHII';
my $regex = qr/^(?=[^0-9]*[0-9])(?=[^a-z]*[a-z])(?=[^A-Z]*[A-Z])[\x21-\x7e]{8,20}$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}