# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-(?=\d+:)/-0/gm;t' <<< "Video 2-1: Title Goes Here"