import Foundation
let pattern = #"-(?=\d+:)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Video 2-1: Title Goes Here"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)