$re = '/-(?=\d+:)/m';
$str = 'Video 2-1: Title Goes Here';
$subst = "-0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;