import re
regex = re.compile(r"-(?=\d+:)", flags=re.MULTILINE)
test_str = "Video 2-1: Title Goes Here"
subst = "-0"
result = regex.sub(subst, test_str)
if result:
print(result)