const regex = /-(?=\d+:)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-(?=\\d+:)', 'gm')
const str = `Video 2-1: Title Goes Here`;
const subst = `-0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);