using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\*\*$)(?!.{9})(?:[A-Za-z]{2}(?:\d*(?:\*\d*)+|\d{6})|\*)$";
string input = @"RIGHT:
*
DE*
de*
GB5*
gb5*
DE*123
DE**123
de*123
DE123456
WRONG:
**
*DE
*de
D
D*
D**
d*
DE
DE123
DE123**
de
D1*
1
1*
123*
1234
DE1234567
DE123456*";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}