re = /^(?!.*\*\*$)(?!.{9})(?:[A-Za-z]{2}(?:\d*(?:\*\d*)+|\d{6})|\*)$/m
str = 'RIGHT:
*
DE*
de*
GB5*
gb5*
DE*123
DE**123
de*123
DE123456
WRONG:
**
*DE
*de
D
D*
D**
d*
DE
DE123
DE123**
de
D1*
1
1*
123*
1234
DE1234567
DE123456*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end