import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\*\\*$)(?!.{9})(?:[A-Za-z]{2}(?:\\d*(?:\\*\\d*)+|\\d{6})|\\*)$";
final String string = "RIGHT:\n"
+ "*\n"
+ "DE*\n"
+ "de*\n"
+ "GB5*\n"
+ "gb5*\n"
+ "DE*123\n"
+ "DE**123\n"
+ "de*123\n"
+ "DE123456\n\n"
+ "WRONG:\n"
+ "**\n"
+ "*DE\n"
+ "*de\n"
+ "D\n"
+ "D*\n"
+ "D**\n"
+ "d*\n"
+ "DE\n"
+ "DE123\n"
+ "DE123**\n"
+ "de\n"
+ "D1*\n"
+ "1\n"
+ "1*\n"
+ "123*\n"
+ "1234\n"
+ "DE1234567\n"
+ "DE123456*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}